SVERWEIS

Dazulesen von Daten anhand einer Nummer aus einer anderen Tabelle:

Tabelle1: Kunden:
A B C
KUNNR NAME ORT
100001 MEYER HANNOVER
100002 MÜLLER HAMBURG
100003 SCHULZE FRANKFURT

Die Tabelle muss aufsteigend sortiert sein, ansonsten liefert SVERWEIS fehlerhafte Ergebnisse!
Tabelle2: Liste
A B C
Kunde NAME ORT
100002 <Formel> <Formel>

 

Formel für NAME:
=WENN(A2<>““;SVERWEIS(A2;Kunden!A:C;2;FALSCH);““)

Formel für Ort:
=WENN(A2<>““;SVERWEIS(A2;Kunden!A:C;3;FALSCH);““)

Erklärung

=WENN(A2<>““; Wenn Kunnr vorhanden, dann Verweis suchen
SVERWEIS(A2; Suchkriterium steht in „A2“
Kunden!A:C; Suchbereich ist Tabelle „Kunden“ Spalten A-C
2; Anzeige bei Treffer: Spalte 2
FALSCH) Genaue Suche!
;““)

Wenn das Suchkriterium nicht in dem Array existiert, dann wird als Ergebnis der Zelleninhalt ausgegeben, der nach der Suchabbruchstelle steht. Es sei denn, man setzt den optionalen zusätzlichen Parameter „Bereichs_Verweis“ auf „Falsch“, dann bekommt man den Fehlerwert #NV wenn das Suchkriterium nicht gefunden wird.
image_pdfimage_print
Enno Wulff
follow me
Letzte Artikel von Enno Wulff (Alle anzeigen)