Komfortable Datums-/Stundeneingabe

Mit Excel lassen sich nur sehr umständlich Zeiten eingeben, da jedesmal der Doppelpunkt als Trennzeichen eingegeben werden muss.Mit folgendem Trick lässt es sich vielleicht komfortabler gestalten

Bei den folgenden Tricks wird die Eingabe nicht umgewandelt, sondern mittels einer Formel in einer zweiten Zelle anders dargestellt.

Zeiteingabe mit Excel (1)

Tragen Sie in der Autokorrektur ein, dass „,,“ durch „:“ ersetzt wird. Eine Zeit lässt sich dann auf dem Ziffernblock einfach mit doppeltem Komma eingeben: 10,,00-> 10:00

Zeiteingabe mit Excel (2)

Eingabe als Stunde und Minute, also 2200 für 22:00 oder 900 für 9:00:
A1: 2200
A2: =TEXT(A1;“0000″)
A3: =VERKETTEN(LINKS(B1;2);“:“;RECHTS(B1;2))
A4: =ZEIT(LINKS(B1;2);RECHTS(B1;2);0)

Und in Kurzform:
A2: =ZEIT(LINKS(TEXT(A1;“0000″);2);RECHTS(TEXT(A1;“0000″);2);0)

Datumseingabe mit Excel (1)

Um ein Datum in der Form „230771“ für den „23.07.1971“ eingeben zu können, kann folgende Formel verwendet werden:

=DATUM(WENN((RECHTS(E2;2)>“50″);(RECHTS(E2;2)+1900);(RECHTS(E2;2)
+2000));TEIL(E2;3;2);(LINKS(E2;2)))

Jahreszahlen größer als 50 werden als Jahreszahl des 20sten Jahrhunderts gerechnet und kleiner 50 für das 21ste Jahrhundert.

Datumseingabe mit Excel (2)

Noch komfortabler geht’s mit folgender Funktion, die auch Eingaben für „2309“ für den 23.09. des aktuellen Jahres ordnungsgemäß umwandelt:
=WENN(E2<>““;
DATUM(WENN(LÄNGE(E2)=4;
JAHR(JETZT());
WENN((RECHTS(E2;2)>“50″);
(RECHTS(E2;2)+1900);
(RECHTS(E2;2)+2000)));
TEIL(E2;3;2);
(LINKS(E2;2)));““)

Übrigens
STRG + .
(Punkt) stellt das aktuelle Datum ins Feld…

Und noch einfacher…

ein Kollege gab mir den folgenden Tipp zur Datumseingabe:

Die Eingabe „Tag – Monat“ wandelt Excel ebenfalls automatisch in ein Datum um. Beispiel: 30-5     –> 30.05. des aktuellen Jahres

image_pdfimage_print
Enno Wulff
follow me
Letzte Artikel von Enno Wulff (Alle anzeigen)